1.1.0-RC2

cpp_logo.png

  • 1.1.0-RC1 has already been released for only ROBOMEC2011 tutorial attendees. Please use 1.1.0-RC1 until 1.1.0-RELEASE is released.
  • RTCs built on 1.0.0 and RTCs built on 1.1.0 have compatibility each other, but tool version should be 1.1.0 when you connect 1.0.0's port and 1.1.0's port, because connection method has been changed.

Source code

C++ source code OpenRTM-aist-1.1.0-RC2.tar.bz2
MD5:fba1dbc10b99381d6c46afd33be4f9ca
2011.06.06
C++ source code OpenRTM-aist-1.1.0-RC2.tar.gz
MD5:86bab7c5153e9d0a3ab12311471e36d3
2011.06.06
C++ source code for Windows OpenRTM-aist-1.1.0-RC2-win32.zip
MD5:5dfb2359c90f86e4674483b19839eaac
2011.06.06

Packages

Windows installer

for Visual Studio 2008
Windows installer OpenRTM-aist-1.1.0-RC2_vc9.msi
MD5:f4f605d8ff3375929a7ab296d792d8bc
2011.06.06
Python Windows installer python-2.6.4.msi python.org
PyYAML (rtc-templateに必要) PyYAML-3.09.win32-py2.6.exe pyyaml.org


  • The Windows installer includes OpenRTM-aist (DLL,header,samples,commands), omniORB-4.1.4, and RTSystemEditor (RCP version). Installing omniORB and the Eclipse tools separately is not necessary.
  • OpenRTM-aist built for Visual Studio 2005 cannot be used with Visual Studio 2008. Download and install the correct package for your development environment.

Linux packages (not provided for RC2)

Linux packages will be provided in the RELEASE version. See the following instructions to build OpenRTM-aist from source code.

Now the deb packages for Ubuntu and Debian, and the rpm packages for Fedora and Vine, are officially supported by distribution source code. You can build OpenRTM-aist packages from source code according to the following process. When you need to make OpenRTM-aist packages, other dependent packages have to be installed before you build it.

 $ tar xvzf OpenRTM-aist-1.1.0-RC1.tar.gz
 $ cd OpenRTM-aist-1.1.0
 $ ./configure --prefix=/usr
 $ cd packages
 $ make

Packages will be generated under the "pacakges" directory.

You can install all dependent packages at once by using the following scripts.

Distributions Supported versions Installation scripts
Vine Linux 4.0, 4.2, 5.0 pkg_install_vine.sh
Fedora 10, 11, 12 (i386/x86_64) pkg_install_fedora.sh
Ubuntu 8.04, 8.10, 9.04, 9.10, 10.04 (i386/x86_64) pkg_install_ubuntu.sh
Debian 3.1 (i386), 4.0, 5.0 (i386/x86_64) pkg_install_debian.sh

Tools

Windows all in one
(RTSystemEditor1.1.0+RTCBUilder1.1.0)
eclipse342_rtmtools110release_win32_ja.zip
MD5:f5619616be753fef7bae9ef863e5b33f
2011.05.24
Linux all in one
(RTSystemEditor1.1.0+RTCBUilder1.1.0)
eclipse342_rtmtools110release_linux_ja.tar.gz
MD5:062355b5963cd0f0a42fb3b8ad43ddc2
2011.05.24

Release note: 1.1.0-RC1

OpenRTM-aist-1.1.0 release candidate version 2 (RC2) has been released in 6 June, 2011. From the OpenRTM-aist Official Website, source code and Windows installer package are available under LGPL license or individual licnese.

  • OpenRTM-aist-1.1.0-RC2.tar.gz -- released in 2011.06.06
    • Some APIs have been added.
      • Call back APIs.
      • Call backs for execution contexts.
    • SDO service frameworks
    • Misc bug fixes.
    • Experimental
      • Observer SDO service has been introduced.
      • CMake file "OpenRTMConfig.cmake" has been introduced (Linux/Windows)
    • Windows installer
      • OpenCV2.1 and some examples are included.
    • Supported OS (build verified)
      • Debian4.0-i686
      • Debian4.0-x86_64
      • Debian5.0-i686
      • Debian5.0-x86_64
      • Fedora release 11 (Leonidas)-i686
      • Fedora release 11 (Leonidas)-x86_64
      • Fedora release 12 (Constantine)-i686
      • Fedora release 12 (Constantine)-x86_64
      • Fedora release 13 (Goddard)-i686
      • Fedora release 13 (Goddard)-x86_64
      • Fedora release 14 (Laughlin)-i686
      • Fedora release 14 (Laughlin)-x86_64
      • FreeBSD7.x-amd64
      • FreeBSD7.x-i386
      • FreeBSD8.x-amd64
      • FreeBSD8.x-i386
      • Ubuntu 8.04-i686
      • Ubuntu 8.04-x86_64
      • Ubuntu 9.10-i686
      • Ubuntu 9.10-x86_64
      • Ubuntu 10.04-i686
      • Ubuntu 10.04-x86_64
      • Ubuntu 10.10-i686
      • Ubuntu 10.10-x86_64
      • Ubuntu 11.04-i686
      • Ubuntu 11.04-x86_64
      • Vine Linux 4.2 (Lynch Bages)-i686
      • Vine Linux 5.0 (Lafite)-i686
      • Windows-XP-VC2005-i386
      • Windows-Vista-VC2008-i386

Old versions

latest Releases

For Begginers

Windows msi(installer) package (only trying samples)

Development environment is required for RT-Component development. See download page for details.

Number of Projects

OpenHRP3

Dynamics simulator

OpenHRI

Human-Robot-Interaction RTCs

OpenRTP

Integrated Development Platform

OpenINVENT

Mobile Robot RTCs