Project

General

Profile

調査 #4636

利用可能なJavaバージョンの調査

Added by ga almost 3 years ago. Updated almost 3 years ago.

Status:
担当
Priority:
通常
Assignee:
Target version:
-
Start date:
12/15/2018
Due date:
% Done:

50%

Estimated time:

Description

Oracle Javaのライセンスおよび新規バージョンにおいてCORBAが削除されることになったことに伴い、また、Eclipseのバージョンアップに伴い、利用可能なJavaバージョン、およびEclipseのバージョンについて調査を行うとともに、今後利用すべきJavaとEclipseについて検討し指針を示すこと。

History

#1 Updated by ga almost 3 years ago

  • Status changed from 新規 to 担当
  • Assignee set to ga
  • % Done changed from 0 to 50

○OpenJDK Ver.8
 Eclipse4.9(最新版)の動作可能
 RTCB, RTSEともにビルド~実行まで問題なし
 RedHatは2023年6月までサポート
○OpenJDK Ver.9,10
 デフォルトでは,CORBA, JAXBが無効となっているため,ビルド自体ができない
 ライブラリ自体は含まれているため,強制的に利用するオプションで有効にすることはできそう
○OpenJDK Ver.11
 CORBA, JAXBが使用できない(ライブラリ自体が含まれていない)
 JAXBについては,代替モジュールあり
 CORBAについては,別途サードパーティ製を使用する必要あり

Also available in: Atom PDF